summaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorpkubaj <pkubaj@35697150-7ecd-e111-bb59-0022644237b5>2021-03-04 19:18:53 +0000
committerpkubaj <pkubaj@35697150-7ecd-e111-bb59-0022644237b5>2021-03-04 19:18:53 +0000
commitbd1cac8a58c7db0f327ec9cc4d7f60f5feec0c88 (patch)
tree82ec4e6adc839d26ac4d717a455cff44ae9c0e05 /biology
parent5928042e499c373d17bd83edf48b6951f1eb3760 (diff)
downloadfreebsd-ports-bd1cac8a58c7db0f327ec9cc4d7f60f5feec0c88.tar.gz
freebsd-ports-bd1cac8a58c7db0f327ec9cc4d7f60f5feec0c88.tar.bz2
biology/spoa: fix build on non-x86
In file included from /wrkdirs/usr/ports/biology/spoa/work/spoa-4.0.7/src/dispatcher.cpp:7: /usr/local/include/cpuinfo_x86.h:228:2: error: "Including cpuinfo_x86.h from a non-x86 target." #error "Including cpuinfo_x86.h from a non-x86 target." git-svn-id: http://svn.freebsd.org/ports/head@567333 35697150-7ecd-e111-bb59-0022644237b5
Diffstat (limited to 'biology')
-rw-r--r--biology/spoa/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/biology/spoa/Makefile b/biology/spoa/Makefile
index 41bdf70f51f7..6a1908b3ff73 100644
--- a/biology/spoa/Makefile
+++ b/biology/spoa/Makefile
@@ -25,11 +25,17 @@ USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= rvaser
-CMAKE_ON= BUILD_SHARED_LIBS spoa_optimize_for_portability spoa_build_executable spoa_use_simde spoa_use_simde_nonvec spoa_use_simde_openmp spoa_generate_dispatch
+CMAKE_ON= BUILD_SHARED_LIBS spoa_optimize_for_portability spoa_build_executable spoa_use_simde spoa_use_simde_nonvec spoa_use_simde_openmp
CMAKE_OFF= spoa_optimize_for_native
LDFLAGS+= -lz -lcpu_features
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == amd64 || ${ARCH} == i386
+CMAKE_ARGS+= -Dspoa_generate_dispatch:BOOL=ON
+.endif
+
do-test:
@cd ${BUILD_WRKSRC} && \
${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -D${PORTNAME}_build_tests:BOOL=ON ${CMAKE_SOURCE_PATH} && \