summaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authoryuri <yuri@35697150-7ecd-e111-bb59-0022644237b5>2021-03-29 21:51:03 +0000
committeryuri <yuri@35697150-7ecd-e111-bb59-0022644237b5>2021-03-29 21:51:03 +0000
commit82fff2fe03b2a8bdb3247a33abe1d2613c468fda (patch)
treed7185d7c6472df254c99a018d487a84ad6120e1c /biology
parentb57b36db4e6a151de96b74d63d795bc4cdd3589a (diff)
downloadfreebsd-ports-82fff2fe03b2a8bdb3247a33abe1d2613c468fda.tar.gz
freebsd-ports-82fff2fe03b2a8bdb3247a33abe1d2613c468fda.tar.bz2
biology/molden: Fix build with gfortran10
git-svn-id: http://svn.freebsd.org/ports/head@569522 35697150-7ecd-e111-bb59-0022644237b5
Diffstat (limited to 'biology')
-rw-r--r--biology/molden/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/biology/molden/Makefile b/biology/molden/Makefile
index 3215b6e7eb69..48cf9422f402 100644
--- a/biology/molden/Makefile
+++ b/biology/molden/Makefile
@@ -73,4 +73,12 @@ do-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${GCC_DEFAULT} >= 10
+# workaround for Type mismatch between actual argument at (1) and actual argument at (2) (INTEGER(4)/REAL(4)).
+# in theory, this should set FCFLAGS, but the port does not conform
+FFLAGS+= -fallow-argument-mismatch
+.endif
+
+.include <bsd.port.post.mk>