summaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authoryuri <yuri@35697150-7ecd-e111-bb59-0022644237b5>2021-03-07 03:43:39 +0000
committeryuri <yuri@35697150-7ecd-e111-bb59-0022644237b5>2021-03-07 03:43:39 +0000
commit3390769c2bcff2b69dde59e5dbcaa12f60314fee (patch)
tree1853c989824df7055a94f1b6edca3a1ec50833e3 /science
parentc6b300e6d6d0968ff59709f162ddec46c8297c94 (diff)
downloadfreebsd-ports-3390769c2bcff2b69dde59e5dbcaa12f60314fee.tar.gz
freebsd-ports-3390769c2bcff2b69dde59e5dbcaa12f60314fee.tar.bz2
science/qbox: Remove unnecessary gcc link flags because the project builds with clang
Reported by: Gerald Pfeifer <gerald@pfeifer.com> git-svn-id: http://svn.freebsd.org/ports/head@567536 35697150-7ecd-e111-bb59-0022644237b5
Diffstat (limited to 'science')
-rw-r--r--science/qbox/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/science/qbox/Makefile b/science/qbox/Makefile
index 1d409c9db3a3..0a67356821dd 100644
--- a/science/qbox/Makefile
+++ b/science/qbox/Makefile
@@ -3,6 +3,7 @@
PORTNAME= qbox
DISTVERSIONPREFIX= rel
DISTVERSION= 1_73_1
+PORTREVISION= 1
CATEGORIES= science
MAINTAINER= yuri@FreeBSD.org
@@ -14,7 +15,6 @@ LICENSE_FILE= ${WRKSRC}/../COPYING
LIB_DEPENDS= libblas.so:math/blas \
libcurl.so:ftp/curl \
libfftw3.so:math/fftw3 \
- libgcc_s.so:lang/gcc${GCC_DEFAULT} \
liblapack.so:math/lapack \
libmpich.so:net/mpich \
libscalapack.so:math/scalapack \
@@ -22,15 +22,16 @@ LIB_DEPENDS= libblas.so:math/blas \
libxerces-c.so:textproc/xerces-c3
USES= compiler:c++11-lang gmake iconv:wchar_t localbase:ldflags
+
USE_GITHUB= yes
GH_ACCOUNT= qboxcode
GH_PROJECT= qbox-public
-ALL_TARGET= qb
WRKSRC_SUBDIR= src
MAKE_ARGS= TARGET=freebsd
-LDFLAGS+= -Wl,-rpath=${LOCALBASE}/lib/gcc${GCC_DEFAULT} ${LOCALBASE}/lib/gcc${GCC_DEFAULT}/libgcc_s.so
+
+ALL_TARGET= qb
PLIST_FILES= bin/qb