summaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authoryuri <yuri@35697150-7ecd-e111-bb59-0022644237b5>2021-03-28 08:39:46 +0000
committeryuri <yuri@35697150-7ecd-e111-bb59-0022644237b5>2021-03-28 08:39:46 +0000
commitb563032e9e0ad17005fa2881b57e66f2e40c7de8 (patch)
treec685c574a2c6a3b53d52f44eda0d10368d27c221 /graphics
parentaf354374aabb9ef1edc31f94c35a157fc5eb8ad1 (diff)
downloadfreebsd-ports-b563032e9e0ad17005fa2881b57e66f2e40c7de8.tar.gz
freebsd-ports-b563032e9e0ad17005fa2881b57e66f2e40c7de8.tar.bz2
graphics/anttweakbar: Add patches to fix several build failures
Reported by: fallout git-svn-id: http://svn.freebsd.org/ports/head@569379 35697150-7ecd-e111-bb59-0022644237b5
Diffstat (limited to 'graphics')
-rw-r--r--graphics/anttweakbar/Makefile2
-rw-r--r--graphics/anttweakbar/files/patch-LoadOGLCore.h16
-rw-r--r--graphics/anttweakbar/files/patch-TwPrecomp.h16
3 files changed, 33 insertions, 1 deletions
diff --git a/graphics/anttweakbar/Makefile b/graphics/anttweakbar/Makefile
index 1bb4d8dfe2d6..cf0453bfb469 100644
--- a/graphics/anttweakbar/Makefile
+++ b/graphics/anttweakbar/Makefile
@@ -20,7 +20,7 @@ USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/AntTweakBar
WRKSRC_SUBDIR= src
-DOS2UNIX_FILES= Makefile
+DOS2UNIX_FILES= Makefile LoadOGLCore.h TwPrecomp.h
LDFLAGS+= -L${LOCALBASE}/lib -lX11
diff --git a/graphics/anttweakbar/files/patch-LoadOGLCore.h b/graphics/anttweakbar/files/patch-LoadOGLCore.h
new file mode 100644
index 000000000000..9d348a0e2a37
--- /dev/null
+++ b/graphics/anttweakbar/files/patch-LoadOGLCore.h
@@ -0,0 +1,16 @@
+- typedefs cause error: typedef redefinition with different types ('ptrdiff_t' (aka 'int') vs 'khronos_intptr_t' (aka 'long'))
+
+--- LoadOGLCore.h.orig 2021-03-28 08:30:01 UTC
++++ LoadOGLCore.h
+@@ -152,9 +152,11 @@ ANT_GL_CORE_DECL(void, glPointParameterfv, (GLenum pna
+ ANT_GL_CORE_DECL(void, glPointParameteri, (GLenum pname, GLint param))
+ ANT_GL_CORE_DECL(void, glPointParameteriv, (GLenum pname, const GLint *params))
+ // GL 1.5
++#if !defined(__FreeBSD__)
+ #ifndef ANT_OSX
+ typedef ptrdiff_t GLintptr;
+ typedef ptrdiff_t GLsizeiptr;
++#endif
+ #endif
+ ANT_GL_CORE_DECL(void, glGenQueries, (GLsizei n, GLuint *ids))
+ ANT_GL_CORE_DECL(void, glDeleteQueries, (GLsizei n, const GLuint *ids))
diff --git a/graphics/anttweakbar/files/patch-TwPrecomp.h b/graphics/anttweakbar/files/patch-TwPrecomp.h
new file mode 100644
index 000000000000..e2c7fb84de8e
--- /dev/null
+++ b/graphics/anttweakbar/files/patch-TwPrecomp.h
@@ -0,0 +1,16 @@
+- error: "<malloc.h> has been replaced by <stdlib.h>"
+
+--- TwPrecomp.h.orig 2021-03-28 08:35:14 UTC
++++ TwPrecomp.h
+@@ -51,7 +51,11 @@
+ # include <GL/glx.h>
+ # include <X11/Xatom.h>
+ # include <unistd.h>
++#if !defined(__FreeBSD__)
+ # include <malloc.h>
++#else
++# include <stdlib.h>
++#endif
+ # undef _WIN32
+ # undef WIN32
+ # undef _WIN64