summaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authoryuri <yuri@35697150-7ecd-e111-bb59-0022644237b5>2021-03-17 22:29:37 +0000
committeryuri <yuri@35697150-7ecd-e111-bb59-0022644237b5>2021-03-17 22:29:37 +0000
commit302d2d70b3c63c8e7989f8c1dc56933554394ca6 (patch)
treee57669f7023ce5150ca540328660f9f696f82f0a /graphics
parent1c48d6fc299b6a0cde3426621acfe0bf9b56a427 (diff)
downloadfreebsd-ports-302d2d70b3c63c8e7989f8c1dc56933554394ca6.tar.gz
freebsd-ports-302d2d70b3c63c8e7989f8c1dc56933554394ca6.tar.bz2
New port: graphics/freetype-gl: C OpenGL Freetype engine library
git-svn-id: http://svn.freebsd.org/ports/head@568693 35697150-7ecd-e111-bb59-0022644237b5
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/freetype-gl/Makefile39
-rw-r--r--graphics/freetype-gl/distinfo7
-rw-r--r--graphics/freetype-gl/pkg-descr4
-rw-r--r--graphics/freetype-gl/pkg-plist16
5 files changed, 67 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 92b177ca167a..27fc7915c606 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -213,6 +213,7 @@
SUBDIR += fraqtive
SUBDIR += freeglut
SUBDIR += freeimage
+ SUBDIR += freetype-gl
SUBDIR += frei0r
SUBDIR += frei0r-plugins
SUBDIR += frei0r-plugins-gavl
diff --git a/graphics/freetype-gl/Makefile b/graphics/freetype-gl/Makefile
new file mode 100644
index 000000000000..6d5fe07903de
--- /dev/null
+++ b/graphics/freetype-gl/Makefile
@@ -0,0 +1,39 @@
+# $FreeBSD$
+
+PORTNAME= freetype-gl
+DISTVERSION= g20210208
+CATEGORIES= graphics
+
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+PATCHFILES= a38359cdcd97bfcf5d02dd65c66f516eac8208ad.patch:-p1 # https://github.com/rougier/freetype-gl/pull/233: Remove the STATIC requirement from the library
+PATCHFILES+= 00a13d4c9e31f9c4e68e8ab30e2f7ec5b0e4bf60.patch:-p1 # https://github.com/rougier/freetype-gl/pull/235: Fix Fontconfig dependency name in demos
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= C OpenGL Freetype engine library
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libfreetype.so:print/freetype2
+TEST_DEPENDS= ImageMagick7-nox11>0:graphics/ImageMagick7-nox11
+
+USES= cmake:noninja gl
+USE_GL= glew
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= rougier
+GH_TAGNAME= 647b062
+
+CMAKE_ON= BUILD_SHARED_LIBS
+CMAKE_OFF= freetype-gl_BUILD_DEMOS freetype-gl_BUILD_APIDOC freetype-gl_BUILD_TESTS # DEMOS depend on graphics/anttweakbar
+
+# DEMOS depend on glfw3
+
+do-test: # build breaks: https://github.com/rougier/freetype-gl/issues/234
+ @cd ${BUILD_WRKSRC} && \
+ ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -Dfreetype-gl_BUILD_TESTS:BOOL=ON ${CMAKE_SOURCE_PATH} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} test
+
+.include <bsd.port.mk>
diff --git a/graphics/freetype-gl/distinfo b/graphics/freetype-gl/distinfo
new file mode 100644
index 000000000000..29ab8c736993
--- /dev/null
+++ b/graphics/freetype-gl/distinfo
@@ -0,0 +1,7 @@
+TIMESTAMP = 1616019755
+SHA256 (rougier-freetype-gl-g20210208-647b062_GH0.tar.gz) = 25623958a56e686626e318e8772d133203e1111a73ec0b4efb8785162541d701
+SIZE (rougier-freetype-gl-g20210208-647b062_GH0.tar.gz) = 11947093
+SHA256 (a38359cdcd97bfcf5d02dd65c66f516eac8208ad.patch) = 36f29ad78708579a26e7bddf0d24746a99c70ea11aa4be53f3636934c8e133c9
+SIZE (a38359cdcd97bfcf5d02dd65c66f516eac8208ad.patch) = 1064
+SHA256 (00a13d4c9e31f9c4e68e8ab30e2f7ec5b0e4bf60.patch) = fec0ebf2439dea2dff47421c06fe79d3c88a6c777091a5a5b729f227a939712a
+SIZE (00a13d4c9e31f9c4e68e8ab30e2f7ec5b0e4bf60.patch) = 967
diff --git a/graphics/freetype-gl/pkg-descr b/graphics/freetype-gl/pkg-descr
new file mode 100644
index 000000000000..c1e4ad2b0319
--- /dev/null
+++ b/graphics/freetype-gl/pkg-descr
@@ -0,0 +1,4 @@
+A small library for displaying Unicode in OpenGL using a single texture and a
+single vertex buffer.
+
+WWW: https://github.com/rougier/freetype-gl
diff --git a/graphics/freetype-gl/pkg-plist b/graphics/freetype-gl/pkg-plist
new file mode 100644
index 000000000000..9325b16c0f1f
--- /dev/null
+++ b/graphics/freetype-gl/pkg-plist
@@ -0,0 +1,16 @@
+include/freetype-gl/distance-field.h
+include/freetype-gl/edtaa3func.h
+include/freetype-gl/font-manager.h
+include/freetype-gl/freetype-gl.h
+include/freetype-gl/markup.h
+include/freetype-gl/opengl.h
+include/freetype-gl/platform.h
+include/freetype-gl/text-buffer.h
+include/freetype-gl/texture-atlas.h
+include/freetype-gl/texture-font.h
+include/freetype-gl/utf8-utils.h
+include/freetype-gl/vec234.h
+include/freetype-gl/vector.h
+include/freetype-gl/vertex-attribute.h
+include/freetype-gl/vertex-buffer.h
+lib/libfreetype-gl.so