summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsunpoet <sunpoet@35697150-7ecd-e111-bb59-0022644237b5>2021-03-30 20:56:01 +0000
committersunpoet <sunpoet@35697150-7ecd-e111-bb59-0022644237b5>2021-03-30 20:56:01 +0000
commitc9e7be1fbadde48681bb33e522dd5474561ebbe8 (patch)
treee2023ee8d9b266f34872d6f7e17c3e014acff014
parentb67c2d4770d3ab977a52f6efb01fe3b3bcb4386b (diff)
downloadfreebsd-ports-c9e7be1fbadde48681bb33e522dd5474561ebbe8.tar.gz
freebsd-ports-c9e7be1fbadde48681bb33e522dd5474561ebbe8.tar.bz2
Build and install example applications
- Bump PORTREVISION for package change git-svn-id: http://svn.freebsd.org/ports/head@569597 35697150-7ecd-e111-bb59-0022644237b5
-rw-r--r--security/nettle/Makefile9
-rw-r--r--security/nettle/files/patch-examples-nettle-openssl.c49
-rw-r--r--security/nettle/pkg-plist13
3 files changed, 70 insertions, 1 deletions
diff --git a/security/nettle/Makefile b/security/nettle/Makefile
index 10764107b1d3..98ba631471b8 100644
--- a/security/nettle/Makefile
+++ b/security/nettle/Makefile
@@ -3,6 +3,7 @@
PORTNAME= nettle
PORTVERSION= 3.7.2
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= GNU \
https://www.lysator.liu.se/~nisse/archive/
@@ -30,6 +31,9 @@ INFO= nettle
OPTIONS_DEFINE= DOCS EXAMPLES
+EXAMPLES_CFLAGS= -I${OPENSSLINC}
+EXAMPLES_USES= ssl
+
.include <bsd.port.options.mk>
.if ${ARCH} == "sparc64"
@@ -37,12 +41,14 @@ CONFIGURE_ENV+= CCPIC=-fPIC
.endif
post-patch:
- @${REINPLACE_CMD} -e '/SUBDIRS = / s| examples||' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e '/libdir=/ s|lib32|lib|' ${WRKSRC}/configure
.if ${ARCH} == "mips64"
@${REINPLACE_CMD} -e 's|__sgi|__unix__|' ${WRKSRC}/configure
.endif
+post-patch-EXAMPLES-off:
+ @${REINPLACE_CMD} -e '/SUBDIRS = / s| examples||' ${WRKSRC}/Makefile.in
+
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lib*.so
@@ -52,6 +58,7 @@ post-install-DOCS-on:
post-install-EXAMPLES-on:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC}/examples && ${INSTALL_PROGRAM} base16dec base16enc base64dec base64enc ecc-benchmark hogweed-benchmark nettle-benchmark random-prime rsa-decrypt rsa-encrypt rsa-keygen rsa-sign rsa-verify ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/*.[ch] ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>
diff --git a/security/nettle/files/patch-examples-nettle-openssl.c b/security/nettle/files/patch-examples-nettle-openssl.c
new file mode 100644
index 000000000000..d7cf037c61c3
--- /dev/null
+++ b/security/nettle/files/patch-examples-nettle-openssl.c
@@ -0,0 +1,49 @@
+--- examples/nettle-openssl.c.orig 2021-03-21 08:32:25 UTC
++++ examples/nettle-openssl.c
+@@ -374,6 +374,7 @@ openssl_hash_update(void *p,
+ EVP_DigestUpdate(ctx->evp, src, length);
+ }
+
++#if OPENSSL_VERSION_NUMBER >= 0x10100000L
+ #define OPENSSL_HASH(NAME, name) \
+ static void \
+ openssl_##name##_init(void *p) \
+@@ -404,6 +405,38 @@ nettle_openssl_##name = { \
+ openssl_hash_update, \
+ openssl_##name##_digest \
+ };
++#else
++#define OPENSSL_HASH(NAME, name) \
++static void \
++openssl_##name##_init(void *p) \
++{ \
++ struct openssl_hash_ctx *ctx = p; \
++ if ((ctx->evp = EVP_MD_CTX_create()) == NULL) \
++ return; \
++ \
++ EVP_DigestInit(ctx->evp, EVP_##name()); \
++} \
++ \
++static void \
++openssl_##name##_digest(void *p, \
++ size_t length, uint8_t *dst) \
++{ \
++ struct openssl_hash_ctx *ctx = p; \
++ assert(length == NAME##_DIGEST_LENGTH); \
++ \
++ EVP_DigestFinal(ctx->evp, dst, NULL); \
++ EVP_DigestInit(ctx->evp, EVP_##name()); \
++} \
++ \
++const struct nettle_hash \
++nettle_openssl_##name = { \
++ "openssl " #name, sizeof(struct openssl_hash_ctx), \
++ NAME##_DIGEST_LENGTH, NAME##_CBLOCK, \
++ openssl_##name##_init, \
++ openssl_hash_update, \
++ openssl_##name##_digest \
++};
++#endif
+
+ OPENSSL_HASH(MD5, md5)
+ OPENSSL_HASH(SHA, sha1)
diff --git a/security/nettle/pkg-plist b/security/nettle/pkg-plist
index 1c870090c412..55cf281c811a 100644
--- a/security/nettle/pkg-plist
+++ b/security/nettle/pkg-plist
@@ -83,23 +83,36 @@ libdata/pkgconfig/nettle.pc
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/nettle.html
%%PORTDOCS%%%%DOCSDIR%%/nettle.pdf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/base16dec
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/base16dec.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/base16enc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/base16enc.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/base64dec
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/base64dec.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/base64enc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/base64enc.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ecc-benchmark
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ecc-benchmark.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hogweed-benchmark
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hogweed-benchmark.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/io.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/io.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/nettle-benchmark
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/nettle-benchmark.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/nettle-openssl.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/random-prime
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/random-prime.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/read_rsa_key.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rsa-decrypt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rsa-decrypt.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rsa-encrypt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rsa-encrypt.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rsa-keygen
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rsa-keygen.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rsa-session.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rsa-sign
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rsa-sign.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rsa-verify
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rsa-verify.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/timing.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/timing.h