summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorrene <rene@35697150-7ecd-e111-bb59-0022644237b5>2020-10-31 10:44:51 +0000
committerrene <rene@35697150-7ecd-e111-bb59-0022644237b5>2020-10-31 10:44:51 +0000
commita1625499c2117e83704f9b0c682ae6efddf0e974 (patch)
tree68e962e86ab020ea3b744758da5058eb4737f821
parent92b1d580c3f4e0f859a2578c490c3eda83d5cbae (diff)
downloadfreebsd-ports-a1625499c2117e83704f9b0c682ae6efddf0e974.tar.gz
freebsd-ports-a1625499c2117e83704f9b0c682ae6efddf0e974.tar.bz2
Remove expired port:
2020-10-30 devel/libsigc++12: Use newer version git-svn-id: http://svn.freebsd.org/ports/head@553767 35697150-7ecd-e111-bb59-0022644237b5
-rw-r--r--MOVED1
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libsigc++12/Makefile26
-rw-r--r--devel/libsigc++12/distinfo2
-rw-r--r--devel/libsigc++12/files/patch-tests_bind__test.cc30
-rw-r--r--devel/libsigc++12/pkg-descr9
-rw-r--r--devel/libsigc++12/pkg-plist34
7 files changed, 1 insertions, 102 deletions
diff --git a/MOVED b/MOVED
index 23ad875d0c17..ef3b076792eb 100644
--- a/MOVED
+++ b/MOVED
@@ -15663,3 +15663,4 @@ net/reposado||2020-10-27|Has expired: Uses deprecated version of python
devel/py-setuptools_darcs||2020-10-27|Has expired: Uses Python 2.7 which is EOLed upstream
devel/py-darcsver||2020-10-27|Has expired: does not build with python3
devel/py-gdata|www/py-google-api-python-client|2020-10-27|Has expired: Unmaintained upstream, superseded by www/py-google-api-python-client
+devel/libsigc++12|devel/libsigc++20|2020-10-31|Has expired: Use newer version
diff --git a/devel/Makefile b/devel/Makefile
index 6b5d3e826ff6..f312190c35ca 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1288,7 +1288,6 @@
SUBDIR += libshbuf
SUBDIR += libshhmsg
SUBDIR += libshhopt
- SUBDIR += libsigc++12
SUBDIR += libsigc++20
SUBDIR += libsigrok
SUBDIR += libsigrokdecode
diff --git a/devel/libsigc++12/Makefile b/devel/libsigc++12/Makefile
deleted file mode 100644
index b13be092e2b8..000000000000
--- a/devel/libsigc++12/Makefile
+++ /dev/null
@@ -1,26 +0,0 @@
-# Created by: Martin Klaffenboeck <martin.klaffenboeck@gmx.at>
-# $FreeBSD$
-
-PORTNAME= libsigc++
-PORTVERSION= 1.2.7
-PORTREVISION= 2
-CATEGORIES= devel
-MASTER_SITES= GNOME
-PKGNAMESUFFIX= 12
-DIST_SUBDIR= gnome2
-
-MAINTAINER= gnome@FreeBSD.org
-COMMENT= Callback Framework for C++
-
-DEPRECATED= Use newer version
-EXPIRATION_DATE= 2020-10-30
-
-LICENSE= LGPL21
-
-GNU_CONFIGURE= yes
-INSTALL_TARGET= install-strip
-USES= gmake libtool pathfix pkgconfig
-USE_LDCONFIG= yes
-BINARY_WRAPPERS= gm4
-
-.include <bsd.port.mk>
diff --git a/devel/libsigc++12/distinfo b/devel/libsigc++12/distinfo
deleted file mode 100644
index b15dbf48ad67..000000000000
--- a/devel/libsigc++12/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (gnome2/libsigc++-1.2.7.tar.gz) = c995a4623d9f71455d8c7d62307a13e68e0f8313f47adb7221421455bbdfcb98
-SIZE (gnome2/libsigc++-1.2.7.tar.gz) = 477083
diff --git a/devel/libsigc++12/files/patch-tests_bind__test.cc b/devel/libsigc++12/files/patch-tests_bind__test.cc
deleted file mode 100644
index 2ef2f7914de5..000000000000
--- a/devel/libsigc++12/files/patch-tests_bind__test.cc
+++ /dev/null
@@ -1,30 +0,0 @@
-libc++ doesn't like "using namespace std" in C++11
-
-bind_test.cc:24:17: error: no viable conversion from '__bind<SigC::Slot1<void, int>, int>' to 'Slot0<void>'
- Slot0<void> s=bind(slot(&foo),1);
- ^ ~~~~~~~~~~~~~~~~~~
-../sigc++/slot.h:207:7: note: candidate constructor not viable: no known conversion from '__bind<SigC::Slot1<void, int>, int>' to 'const SigC::Slot0<void> &' for 1st argument
- Slot0(const Slot0& s)
- ^
-../sigc++/slot.h:210:7: note: candidate constructor not viable: no known conversion from '__bind<SigC::Slot1<void, int>, int>' to 'SigC::SlotNode *' for 1st argument
- Slot0(SlotNode* node)
- ^
-../sigc++/slot.h:213:7: note: candidate constructor not viable: no known conversion from '__bind<SigC::Slot1<void, int>, int>' to 'SigC::Slot0<void>::Callback' (aka 'void (*)()') for 1st argument
- Slot0(Callback callback)
- ^
-
---- tests/bind_test.cc.orig 2002-10-11 12:42:15 UTC
-+++ tests/bind_test.cc
-@@ -21,10 +21,10 @@ void foo2(A) { cout << "foo2(A)" <<endl; result+=3;}
- int main()
- {
- cout << ">>test 1"<<endl;
-- Slot0<void> s=bind(slot(&foo),1);
-+ Slot0<void> s=SigC::bind(slot(&foo),1);
- s();
- cout << ">>test 2"<<endl;
-- s=bind(slot(&foo2),1);
-+ s=SigC::bind(slot(&foo2),1);
- s();
- cout << ">>test 3"<<endl;
- s.clear();
diff --git a/devel/libsigc++12/pkg-descr b/devel/libsigc++12/pkg-descr
deleted file mode 100644
index ca75484bae55..000000000000
--- a/devel/libsigc++12/pkg-descr
+++ /dev/null
@@ -1,9 +0,0 @@
-Libsigc++ -- The Typesafe Callback Framework for C++
-
-This library implements a full callback system for use in widget libraries,
-abstract interfaces, and general programming.
-
-To get a good overview of how to use the library, read
-/usr/local/share/doc/libsigc++/signals.
-
-WWW: http://libsigc.sourceforge.net/
diff --git a/devel/libsigc++12/pkg-plist b/devel/libsigc++12/pkg-plist
deleted file mode 100644
index 05bed4b39241..000000000000
--- a/devel/libsigc++12/pkg-plist
+++ /dev/null
@@ -1,34 +0,0 @@
-include/sigc++-1.2/sigc++/adaptor.h
-include/sigc++-1.2/sigc++/bind.h
-include/sigc++-1.2/sigc++/bind_return.h
-include/sigc++-1.2/sigc++/class_slot.h
-include/sigc++-1.2/sigc++/connection.h
-include/sigc++-1.2/sigc++/hide.h
-include/sigc++-1.2/sigc++/macros/bind.h.m4
-include/sigc++-1.2/sigc++/macros/bind_return.h.m4
-include/sigc++-1.2/sigc++/macros/class_slot.h.m4
-include/sigc++-1.2/sigc++/macros/hide.h.m4
-include/sigc++-1.2/sigc++/macros/method_slot.h.m4
-include/sigc++-1.2/sigc++/macros/object_slot.h.m4
-include/sigc++-1.2/sigc++/macros/retype.h.m4
-include/sigc++-1.2/sigc++/macros/retype_return.h.m4
-include/sigc++-1.2/sigc++/macros/signal.h.m4
-include/sigc++-1.2/sigc++/macros/slot.h.m4
-include/sigc++-1.2/sigc++/macros/template.macros.m4
-include/sigc++-1.2/sigc++/marshal.h
-include/sigc++-1.2/sigc++/method_slot.h
-include/sigc++-1.2/sigc++/node.h
-include/sigc++-1.2/sigc++/object.h
-include/sigc++-1.2/sigc++/object_slot.h
-include/sigc++-1.2/sigc++/retype.h
-include/sigc++-1.2/sigc++/retype_return.h
-include/sigc++-1.2/sigc++/sigc++.h
-include/sigc++-1.2/sigc++/signal.h
-include/sigc++-1.2/sigc++/slot.h
-include/sigc++-1.2/sigc++/trait.h
-lib/libsigc-1.2.a
-lib/libsigc-1.2.so
-lib/libsigc-1.2.so.5
-lib/libsigc-1.2.so.5.0.7
-lib/sigc++-1.2/include/sigcconfig.h
-libdata/pkgconfig/sigc++-1.2.pc