summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjbeich <jbeich@35697150-7ecd-e111-bb59-0022644237b5>2021-03-30 14:18:53 +0000
committerjbeich <jbeich@35697150-7ecd-e111-bb59-0022644237b5>2021-03-30 14:18:53 +0000
commit92804dda61efc2950d1537f7de77b73ae11c0c45 (patch)
tree21874bd34c3254c6cc89cbfca207e58e81b5b263
parent1698bb297f1a1f118f6da54a2ef0eb35f2f39ee9 (diff)
downloadfreebsd-ports-92804dda61efc2950d1537f7de77b73ae11c0c45.tar.gz
freebsd-ports-92804dda61efc2950d1537f7de77b73ae11c0c45.tar.bz2
devel/intel-graphics-compiler: update to 1.0.6812
Changes: https://github.com/intel/intel-graphics-compiler/releases/tag/igc-1.0.6812 Reported by: GitHub (watch releases) git-svn-id: http://svn.freebsd.org/ports/head@569559 35697150-7ecd-e111-bb59-0022644237b5
-rw-r--r--devel/intel-graphics-compiler/Makefile11
-rw-r--r--devel/intel-graphics-compiler/distinfo12
-rw-r--r--devel/intel-graphics-compiler/files/patch-llvm24
-rw-r--r--devel/intel-graphics-compiler/files/patch-llvm1128
-rw-r--r--devel/intel-graphics-compiler/files/patch-unix31
5 files changed, 34 insertions, 72 deletions
diff --git a/devel/intel-graphics-compiler/Makefile b/devel/intel-graphics-compiler/Makefile
index dc6c87bc0768..fa3f61743eb7 100644
--- a/devel/intel-graphics-compiler/Makefile
+++ b/devel/intel-graphics-compiler/Makefile
@@ -2,12 +2,9 @@
PORTNAME= intel-graphics-compiler
DISTVERSIONPREFIX= igc-
-DISTVERSION= 1.0.6712
+DISTVERSION= 1.0.6812
CATEGORIES= devel
-PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
-PATCHFILES+= 996e2fe60899.patch:-p1 # https://github.com/intel/intel-graphics-compiler/pull/173
-
MAINTAINER= jbeich@FreeBSD.org
COMMENT= Intel Graphics Compiler for OpenCL
@@ -23,7 +20,7 @@ USES= bison cmake compiler:c++17-lang python:build
USE_GITHUB= yes
USE_LDCONFIG= yes
GH_ACCOUNT= intel
-GH_TUPLE= intel:vc-intrinsics:e7837b2:vcintrin/../vc-intrinsics
+GH_TUPLE= intel:vc-intrinsics:e657f3b:vcintrin/../vc-intrinsics
CMAKE_OFF= INSTALL_SPIRVDLL
CFLAGS+= -Wno-macro-redefined # __fastcall
PLIST_SUB= ARCH_SUFX=${ARCH:S/i386/32/:S/amd//:S/x86_//}
@@ -34,10 +31,10 @@ post-patch:
-e '/EXECUTABLE/s/"python"/"${PYTHON_CMD:T}"/' \
-e '/IGC_PYTHON/s/"python"/"${PYTHON_CMD:T}"/' \
${WRKSRC}/IGC/CMakeLists.txt \
- ${WRKSRC}/IGC/BiFModule/CMakeLists.txt
+ ${WRKSRC}/IGC/BiFModule/linux/CMakeLists.txt
# devel/llvm* have different naming from upstream under PATH
@${REINPLACE_CMD} -e '/clang-\$$/s//clang$$/' \
- ${WRKSRC}/IGC/BiFModule/CMakeLists.txt
+ ${WRKSRC}/IGC/cmake/find_opencl_clang.cmake
# No need to abort on every benign warning enabled by default
@${REINPLACE_CMD} -e 's/"-Werror"//; /-Werror/d' \
${WRKSRC}/IGC/CMakeLists.txt
diff --git a/devel/intel-graphics-compiler/distinfo b/devel/intel-graphics-compiler/distinfo
index e6330a96de2d..e9dd0f6d5ccd 100644
--- a/devel/intel-graphics-compiler/distinfo
+++ b/devel/intel-graphics-compiler/distinfo
@@ -1,7 +1,5 @@
-TIMESTAMP = 1615644394
-SHA256 (intel-intel-graphics-compiler-igc-1.0.6712_GH0.tar.gz) = 1e5d63337ccbf8304c34b045b66e6e8411ce7d95b8f34c5abff17f6e60033eb0
-SIZE (intel-intel-graphics-compiler-igc-1.0.6712_GH0.tar.gz) = 7349537
-SHA256 (intel-vc-intrinsics-e7837b2_GH0.tar.gz) = 1f5328860688c2191d54687a7866fc393f7cc6a30de7b10689c1a081ef14880a
-SIZE (intel-vc-intrinsics-e7837b2_GH0.tar.gz) = 122381
-SHA256 (996e2fe60899.patch) = bd28197532678ed6506321223a64b28b957ce83289ea082cb88c826cc59e3052
-SIZE (996e2fe60899.patch) = 1537
+TIMESTAMP = 1616406924
+SHA256 (intel-intel-graphics-compiler-igc-1.0.6812_GH0.tar.gz) = 9685886963b516c8cbb8af1950389b86c0f4ee5c299dd06563a33cf7ade379f4
+SIZE (intel-intel-graphics-compiler-igc-1.0.6812_GH0.tar.gz) = 7377445
+SHA256 (intel-vc-intrinsics-e657f3b_GH0.tar.gz) = ba5192a940158bac0979a4fc567ba3442815dfade2f38e2467ccc226d9a104dc
+SIZE (intel-vc-intrinsics-e657f3b_GH0.tar.gz) = 124133
diff --git a/devel/intel-graphics-compiler/files/patch-llvm b/devel/intel-graphics-compiler/files/patch-llvm
deleted file mode 100644
index d41986772476..000000000000
--- a/devel/intel-graphics-compiler/files/patch-llvm
+++ /dev/null
@@ -1,24 +0,0 @@
-Don't look for libLLVM without llvm-config or LLVM.cmake help
-
--- [IGC] LLVM targets are not defined. Searching for LLVM.
--- [IGC] Using system LLVM 10.0.0
-CMake Error at IGC/CMakeLists.txt:3283 (message):
- [IGC] Could not find the LLVM dylib. Aborting.
-
---- external/llvm/llvm.cmake.orig 2021-02-15 09:29:30 UTC
-+++ external/llvm/llvm.cmake
-@@ -157,12 +157,8 @@ if(LLVM_LINK_LLVM_DYLIB)
- set(IGC_BUILD__LLVM_LIBS_TO_LINK "${SET_LLVM_LIB_PATH}/libLLVM-${LLVM_VERSION_MAJOR}.so")
- message(STATUS "[IGC] Link against specified LLVM dylib ${IGC_BUILD__LLVM_LIBS_TO_LINK}")
- else()
-- find_library(IGC_BUILD__LLVM_LIBS_TO_LINK "libLLVM-${LLVM_VERSION_MAJOR}.so")
-- if(IGC_BUILD__LLVM_LIBS_TO_LINK)
-- message(STATUS "[IGC] Link against found LLVM dylib ${IGC_BUILD__LLVM_LIBS_TO_LINK}")
-- else()
-- message(FATAL_ERROR "[IGC] Could not find the LLVM dylib. Aborting.")
-- endif()
-+ set(IGC_BUILD__LLVM_LIBS_TO_LINK "LLVM")
-+ message(STATUS "[IGC] Link against LLVM dylib")
- endif()
-
- else()
diff --git a/devel/intel-graphics-compiler/files/patch-llvm11 b/devel/intel-graphics-compiler/files/patch-llvm11
index 83daffcb7d18..0607d49ebf71 100644
--- a/devel/intel-graphics-compiler/files/patch-llvm11
+++ b/devel/intel-graphics-compiler/files/patch-llvm11
@@ -1,16 +1,16 @@
-IGC/Compiler/ConvertMSAAPayloadTo16Bit.cpp:158:35: error: no member named 'getVectorElementType' in 'llvm::Type'; did you mean 'getPointerElementType'?
- ldmcs->getType()->getVectorElementType()->isFloatTy())
+IGC/Compiler/ConvertMSAAPayloadTo16Bit.cpp:156:35: error: no member named 'getVectorElementType' in 'llvm::Type'; did you mean 'getPointerElementType'?
+ ldmcs->getType()->getVectorElementType() == m_builder->getInt32Ty())
^~~~~~~~~~~~~~~~~~~~
getPointerElementType
/usr/local/llvm11/include/llvm/IR/Type.h:370:9: note: 'getPointerElementType' declared here
Type *getPointerElementType() const {
^
-IGC/Compiler/ConvertMSAAPayloadTo16Bit.cpp:162:61: error: no member named 'getVectorNumElements' in 'llvm::Type'
+IGC/Compiler/ConvertMSAAPayloadTo16Bit.cpp:160:61: error: no member named 'getVectorNumElements' in 'llvm::Type'
uint ldmcsNumOfElements = ldmcs->getType()->getVectorNumElements();
~~~~~~~~~~~~~~~~ ^
-IGC/Compiler/ConvertMSAAPayloadTo16Bit.cpp:163:75: error: no member named 'getVectorNumElements' in 'llvm::Type'
- uint new_mcs_callNumOfElements = new_mcs_call->getType()->getVectorNumElements();
- ~~~~~~~~~~~~~~~~~~~~~~~ ^
+IGC/Compiler/ConvertMSAAPayloadTo16Bit.cpp:161:71: error: no member named 'getVectorNumElements' in 'llvm::Type'
+ uint newLdmcsNumOfElements = new_mcs_call->getType()->getVectorNumElements();
+ ~~~~~~~~~~~~~~~~~~~~~~~ ^
IGC/Compiler/Legalizer/InstPromoter.cpp:402:42: error: no member named 'getVectorNumElements' in 'llvm::Type'
for (unsigned i = 0; i < DestTy->getVectorNumElements(); i++)
@@ -30,30 +30,30 @@ bool RecursivelyDeleteTriviallyDeadInstructions(
void RecursivelyDeleteTriviallyDeadInstructions(
^
---- IGC/Compiler/ConvertMSAAPayloadTo16Bit.cpp.orig 2021-02-15 09:29:30 UTC
+--- IGC/Compiler/ConvertMSAAPayloadTo16Bit.cpp.orig 2021-03-22 09:55:24 UTC
+++ IGC/Compiler/ConvertMSAAPayloadTo16Bit.cpp
-@@ -155,12 +155,21 @@ void ConvertMSAAPayloadTo16Bit::visitCallInst(CallInst
- // In OGL there are uses of ldmcs other then ldms, using vec4float type.
+@@ -153,12 +153,21 @@ void ConvertMSAAPayloadTo16Bit::visitCallInst(CallInst
+ // There are uses of ldmcs other then ldms, using vector of int32 type.
// Fix them to use newly created 16bit ldmcs.
if (ldmcs->getType()->isVectorTy() &&
+#if LLVM_VERSION_MAJOR < 11
- ldmcs->getType()->getVectorElementType()->isFloatTy())
+ ldmcs->getType()->getVectorElementType() == m_builder->getInt32Ty())
+#else
-+ cast<llvm::VectorType>(ldmcs->getType())->getElementType()->isFloatTy())
++ cast<llvm::VectorType>(ldmcs->getType())->getElementType() == m_builder->getInt32Ty())
+#endif
{
m_builder->SetInsertPoint(ldmcs);
+#if LLVM_VERSION_MAJOR < 11
uint ldmcsNumOfElements = ldmcs->getType()->getVectorNumElements();
- uint new_mcs_callNumOfElements = new_mcs_call->getType()->getVectorNumElements();
+ uint newLdmcsNumOfElements = new_mcs_call->getType()->getVectorNumElements();
+#else
+ uint ldmcsNumOfElements = cast<llvm::VectorType>(ldmcs->getType())->getNumElements();
-+ uint new_mcs_callNumOfElements = cast<llvm::VectorType>(new_mcs_call->getType())->getNumElements();
++ uint newLdmcsNumOfElements = cast<llvm::VectorType>(new_mcs_call->getType())->getNumElements();
+#endif
// vec of 16bit ints to vec of 32bit ints
- Type* new_mcs_callVecType = VectorType::get(m_builder->getInt32Ty(), new_mcs_callNumOfElements);
+ Type* newLdmcsVecType = VectorType::get(m_builder->getInt32Ty(), newLdmcsNumOfElements);
--- IGC/Compiler/Legalizer/InstPromoter.cpp.orig 2021-02-08 08:48:29 UTC
+++ IGC/Compiler/Legalizer/InstPromoter.cpp
@@ -399,7 +399,11 @@ bool InstPromoter::visitBitCastInst(BitCastInst& I) {
diff --git a/devel/intel-graphics-compiler/files/patch-unix b/devel/intel-graphics-compiler/files/patch-unix
index 65e1dc3e7f18..c7eeaec1f03f 100644
--- a/devel/intel-graphics-compiler/files/patch-unix
+++ b/devel/intel-graphics-compiler/files/patch-unix
@@ -159,26 +159,6 @@ CMake Error at IGC/CMakeLists.txt:1974 (message):
if (IGC_IS_FLAG_ENABLED(EnableDPEmulation)) {
return true;
}
---- IGC/AdaptorOCL/ocl_igc_interface/impl/fcl_ocl_translation_ctx_impl.cpp.orig 2020-11-21 02:52:12 UTC
-+++ IGC/AdaptorOCL/ocl_igc_interface/impl/fcl_ocl_translation_ctx_impl.cpp
-@@ -64,7 +64,7 @@ SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
-
- #include <memory>
-
--#if defined(__linux__)
-+#if defined(__unix__)
- #include <dlfcn.h>
- #else
- #include <Windows.h>
-@@ -132,7 +132,7 @@ llvm::Optional<std::vector<char>> readBinaryFile(const
- #if !defined(WDDM_LINUX) && (!defined(IGC_VC_DISABLED) || !IGC_VC_DISABLED)
-
- static std::string detectCmIncludes(llvm::sys::DynamicLibrary &LibInfo) {
--#if defined(__linux__)
-+#if defined(__unix__)
- #define GetFunctionNameAsStr(s) ((void)s, #s);
- const char *SymName = GetFunctionNameAsStr(IntelCMClangFECompile);
- void *FAddr = LibInfo.getAddressOfSymbol(SymName);
--- IGC/GenISAIntrinsics/GenIntrinsics.h.orig 2020-02-10 06:06:31 UTC
+++ IGC/GenISAIntrinsics/GenIntrinsics.h
@@ -67,7 +67,7 @@ namespace GenISAIntrinsic {
@@ -262,6 +242,17 @@ CMake Error at IGC/CMakeLists.txt:1974 (message):
# pragma GCC diagnostic push
# if __GNUC__ > 8
# pragma GCC diagnostic ignored "-Winit-list-lifetime"
+--- IGC/common/Stats.cpp.orig 2021-03-22 09:55:24 UTC
++++ IGC/common/Stats.cpp
+@@ -1061,7 +1061,7 @@ void TimeStats::printTimeCSV( std::string const& corpu
+ else
+ subFile += IGC::Debug::GetShaderCorpusName();
+ const std::string outputFilePath =
+-#if defined(__linux__)
++#if !defined(_WIN32)
+ subFile + ".csv";
+ #else
+ std::string("c:\\Intel\\") + subFile + ".csv";
--- IGC/common/igc_regkeys.hpp.orig 2019-11-27 01:05:20 UTC
+++ IGC/common/igc_regkeys.hpp
@@ -39,7 +39,7 @@ typedef char debugString[256];