summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoryuri <yuri@35697150-7ecd-e111-bb59-0022644237b5>2021-03-31 03:11:13 +0000
committeryuri <yuri@35697150-7ecd-e111-bb59-0022644237b5>2021-03-31 03:11:13 +0000
commit1f7ca75520289e6ae91ae8bd732ecd9eb241dd1a (patch)
tree8681d3b16e2bf7e27defa349ee29b872f31dec1c
parentbce8c0595a9dae88c6f404be13a1807f377f3f1b (diff)
downloadfreebsd-ports-1f7ca75520289e6ae91ae8bd732ecd9eb241dd1a.tar.gz
freebsd-ports-1f7ca75520289e6ae91ae8bd732ecd9eb241dd1a.tar.bz2
multimedia/simplescreenrecorder: Improve and add to options
* Add JACK option * Make ALSA off by default * Add V4L option for dependency on multimedia/libv4l * Add option group AUDIO git-svn-id: http://svn.freebsd.org/ports/head@569608 35697150-7ecd-e111-bb59-0022644237b5
-rw-r--r--multimedia/simplescreenrecorder/Makefile19
1 files changed, 13 insertions, 6 deletions
diff --git a/multimedia/simplescreenrecorder/Makefile b/multimedia/simplescreenrecorder/Makefile
index 0581ca4ffb2b..7531a305774d 100644
--- a/multimedia/simplescreenrecorder/Makefile
+++ b/multimedia/simplescreenrecorder/Makefile
@@ -2,6 +2,7 @@
PORTNAME= simplescreenrecorder
DISTVERSION= 0.4.3
+PORTREVISION= 1
CATEGORIES= multimedia
MAINTAINER= yuri@FreeBSD.org
@@ -11,22 +12,25 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= v4l_compat>0:multimedia/v4l_compat
-LIB_DEPENDS= libavformat.so:multimedia/ffmpeg \
- libv4l2.so:multimedia/libv4l
+LIB_DEPENDS= libavformat.so:multimedia/ffmpeg
USES= cmake compiler:c++11-lang pkgconfig qt:5 xorg
+USE_QT= core gui widgets x11extras buildtools_build linguisttools_build qmake_build
+USE_XORG= x11 xext xfixes xi xinerama
+
USE_GITHUB= yes
GH_ACCOUNT= MaartenBaert
GH_PROJECT= ssr
-USE_QT= core gui widgets x11extras buildtools_build linguisttools_build qmake_build
-USE_XORG= x11 xext xfixes xi xinerama
CMAKE_ON= WITH_QT5
CMAKE_OFF= WITH_GLINJECT # doesn't yet work on FreeBSD: https://github.com/MaartenBaert/ssr/issues/586#issuecomment-343780107
CMAKE_OFF+= WITH_OPENGL_RECORDING # extra option requiried when GLInject is off, because this makes OpenGL recording dysfunctional
-OPTIONS_DEFINE= ALSA PULSEAUDIO JACK
-OPTIONS_DEFAULT= ALSA PULSEAUDIO
+OPTIONS_DEFINE= V4L
+OPTIONS_MULTI= AUDIO # MULTI because project doesn't allow to build with no backends
+OPTIONS_MULTI_AUDIO= ALSA PULSEAUDIO JACK
+OPTIONS_DEFAULT= PULSEAUDIO JACK V4L
+AUDIO_DESC= Audio backends:
ALSA_CMAKE_BOOL= WITH_ALSA
ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
@@ -37,6 +41,9 @@ PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
JACK_CMAKE_BOOL= WITH_JACK
JACK_LIB_DEPENDS= libjack.so:audio/jack
+V4L_CMAKE_BOOL= WITH_V4L2
+V4L_LIB_DEPENDS= libv4l2.so:multimedia/libv4l
+
post-install: # https://github.com/MaartenBaert/ssr/issues/609
@${RM} ${STAGEDIR}${PREFIX}/man/man1/ssr-glinject.*