summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsunpoet <sunpoet@35697150-7ecd-e111-bb59-0022644237b5>2021-03-30 19:16:51 +0000
committersunpoet <sunpoet@35697150-7ecd-e111-bb59-0022644237b5>2021-03-30 19:16:51 +0000
commit1c8296b60fa67e7c787119f62cf924b2dd2a442f (patch)
tree4e72210e9eadddaa4f08372e9d8139cea2811fba
parentb3426d1f90b633ec761bea746bdcb8fe1ca0e70e (diff)
downloadfreebsd-ports-1c8296b60fa67e7c787119f62cf924b2dd2a442f.tar.gz
freebsd-ports-1c8296b60fa67e7c787119f62cf924b2dd2a442f.tar.bz2
Fix build with Python 3.8+
PR: 254503 Submitted by: kai git-svn-id: http://svn.freebsd.org/ports/head@569586 35697150-7ecd-e111-bb59-0022644237b5
-rw-r--r--x11-fonts/py-opentype-sanitizer/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/x11-fonts/py-opentype-sanitizer/Makefile b/x11-fonts/py-opentype-sanitizer/Makefile
index 2d603f7d1a93..4aade5f5270e 100644
--- a/x11-fonts/py-opentype-sanitizer/Makefile
+++ b/x11-fonts/py-opentype-sanitizer/Makefile
@@ -21,6 +21,12 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR}
USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} >= 3800
+LDFLAGS+= -lpython${PYTHON_VER}
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/src/python/ots/__init__.py
@${RM} -r ${WRKSRC}/src/c/
@@ -31,4 +37,4 @@ post-install:
do-test:
cd ${WRKSRC}/ && ${PYTHON_CMD} -m pytest -v
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>